Резервирование каналов RouterOS по приоритету маршрутов

Простой способ настроить резервирование, используя приоритет маршрута, а так же механизм проверки доступности шлюза — check-gateway.

В приведенной ниже конфигурации весь интернет трафик по умолчанию ходит через 10.10.1.254 (WAN1). Но как только адрес 10.10.1.254 станет недоступным (а маршрут через него неактивным) — трафик пойдет через 10.20.1.254 (WAN2).

конфигурация:

# Настройка провайдеров:
 /ip address add address=10.10.1.1/24 interface=WAN1
 /ip address add address=10.20.1.1/24 interface=WAN2
 # Настроим локальный интерфейс
 /ip address add address=172.16.10.1/24 interface=Bridge-Local
 # NAT для локальной сети
 /ip firewall nat add src-address=172.16.10.0/24 action=masquerade chain=srcnat
 ###Обеспечение резервирования каналов###
 # укажем 2 шлюза по умолчанию с разными приоритетами
 /ip route add dst-address=0.0.0.0/0 gateway=10.10.1.254 distance=1 check-gateway=ping
 /ip route add dst-address=0.0.0.0/0 gateway=10.20.1.254 distance=2 check-gateway=ping

check-gateway=ping – обрабатывается так:
Периодически (каждые 10 секунд) шлюз проверяется отсылкой на него ICMP пакета (ping). Потерянным пакет считается, если он не вернулся в течении 10 секунд. После двух потерянных пакетов шлюз считается недоступным. После получения ответа от шлюза он становится доступным и счетчик потерянных пакетов сбрасывается.